After taking delivery of my new-to-me (refurbished) Linksys WRT 3200ACM router, I was excited to see how fast my wireless network would be when compared to my very old D-Link wireless router.  It didn’t take long before the air was let out of my balloon, unfortunately.  For reasons I couldn’t understand, it seemed that all my wireless devices were now ridiculously slow in loading web pages that once worked just fine.  Not what I expected from a $300 wireless router.

The Symptoms

The bulk of the devices on my home network are Windows 10 devices, including two Windows 10 phones (Yeah, I know).  Having just recently updated all devices with the latest Windows updates, I thought for sure that Microsoft had introduced a defect that was causing all of my devices to take forever to load web pages.   In addition, I couldn’t even access certain URLs such as https://www.outlook.com/!

Mobile applications, such as my weather app, were also loading slowly because most of them fetch their data from a web service somewhere on the Interwebs.  If I was only having issues on one of my devices, I might’ve suspected the unique device, but since the slowness issue seemed universal across devices, I was very suspect of my new router.

The Solution

After many hours of searching and playing with settings on the router, simply disabling IPv6 on the router seems to have done the trick.  I found this tip from another frustrated WRT3200ACM owner on the Linksys forums.  While some Internet Service Providers support IPv6, including my ISP Spectrum Cable, it’s apparently not a standard across the entire Internet and so “user beware”.

It’s probably a bit soon for me to declare the Linksys WRT3200ACM router as the perfect router, but now that I got past this little hiccup, I am very happy with the router.